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(Correlation)
T 3724 AEEM o] SESIEfO|L, SiLo| SRMAS EHM JIE HE
(Simple Regression) Ol Ciol KIS atS dde = U= YEE &E TS,
OE 3 HEN oY S| HEMO| =E HHZ, 2] JHe| K EH+E Sot BE
(Multiple Regression) MM TS,
20IFA TEH EO &R Ha ALO]Q] HAEXM
(Factor Analysis)
Az C1F 317240 SRHER 0f2f Mol gSHao] X3S 5
(Path Analysis) 3 013 Ho| ZABAE MHSHAL 5T 2 US
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O AI2Xt SAo| GUI M2 =2

o XHXE 28 7H55l0] Learning Cost, Z& 74

® SPSS Statistics@t HZASIY L2 EA 241t

ChoteAtQL OtO| 2 S 0|8 1= &

A Unnamed project : Graup number 1 : Input
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Path disgram | Tables
Nt estimating any user-defined estimand.

o EMXI7L HE F2 EHE X3
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Statistics@t & 7ts

80 NN T UED PED B RS GWPHL SPD YW SAVM Wi et

A8 1015141 £0) - 81 P55 Satatics Dt bt - ol

ETT Y-

Auenem
now vE

PEE Aeld

b

e 8 s ZEAN SR | [

* Amos H& HX| oo

Ctst X| 2SS M350 2MXte| oJAtAd x|

1) ECHXNBX]|a= (GFl, RMSEA, SRMR) 5 1EX|== (T-value)

2) SEX K|S (CFI, NFI, NNFI) 6) CH= A2HH&E(SMO)

3) ZFHATX|$(AIC, BCC) 7). Z8A = (coef. Of determinant)

4) = X|F= (modification index)

MZ2 o|2o| 1xHA o H 7}

1) HO|X|et=T - 4) =M HOHe #& X 24 7|5
2) U3 At= OfAM| 3 2 QHEH =Tt 5) 2% 222 (Mixture-Modeling)

3) & HU XEO i 28 =8 7|5

Ctst X2 L= Access

(SPSS, Excel, MS-Access, Text, Lotus, D-Base, Fox-pro)
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Amos &2 £% 7|5 (1)

O Graphic User Interface
BE ZRo #A 8 EHS AFAL ARHoZ HH A S0 22 OhF, Bz O
BAE HY AL A2 LIEFLYY| 7ts

1) 7|ZQ| LISREL ol =2y
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Ral
10

2) ZEAS0| 2 TEYYY BES Y
) AN 4 U 282 Teret| 412

Chi-square = lcmin (\df df)
4) Z2 BAC X7 Tpofo| B 412

O Bootstrapping

SAHY FF2 4% 40| W2 ZZ SAZ 78 A Mo 7| W20

o)

ol2{st MU 22 H XtR&E7| ?I5+0 Bootstrapping= AHE

1) AMOSZt X| &35
- ADF : 2AMN
- MLE: X|@ =
- GLS : ¥Htz} X
- SLS : Scale-fre
- ULS : u|7r§ x

(o)l
0%
> IF

|'>ﬁ >
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<l
ifd]

2) 7|@Xo2 UtEX o2 [0|HE RandomdtH FEH0 FYXIE A Lt
Chg, 20 =S LIEtW = HS dEsts S -

3) SAH FEYR- H|usty FH O E F2s ot A2, 0[0f HE Hu
=42 SoHA HH FZXE dH

4) At=o| 37|17t 2 20| 2HO|Lt =HA|ZHo] 22f ZE
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O Modification Indices
HAILESO| ZAO| MASHE AH AIXISO|A X7 A2 £8o| Mt S =0|7|
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Modification Indices (Group number 1 - Default model)

| Covariances: (Group number 1 - Default model)
S A SN ™St 2 =0|7| 2|5t MI  Par Change
2) & = £ 0” -I’ HEE = | l Tl = zeta <> freatment 46644 862
o ol T =2 17 oy =L _— epsd <--> treatment 10.116 399
ol AAHE EAISHY F= K& eps3 <> featment 14.836 476
eps2 <--> treatment 17.650 -494
3) MIXIEZO| 52 £ 289 HAS X oot <> weoment | 567 27

—_ o Variances: (Group number 1 - Default model)
=4 X8 = A4S ot
o

MI  Par Change

= Regression Weights: (Group number 1 - Default model)
| A =
4) 1 20f 7|2Xoz HHol 229 2A 7t ML Par Change
o post_verbal <--- treatment 44333 3436
— o AT
WA Q= AL 3l M XS X3S0 L] postopp < teamem 9607 1597
post_syn  <--- treatment 14.149 1.909
<= =0 al pre_opp  <--- treatment 16.775 -1.978
F= 7150l M pre_syn <- treatment 5216 1113

o Hlo| x|t =Y
MCMC(OIREH O/ 2HZ2) S 0|83, B
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- D EO| parameterOf CHSH AFN HE K|
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2) EXMFED Ao Glo|E XES
RS 2 0|, AFRRIT} H 2|8
S0 EHE & 4 YUs 7|5 AEB
3) @40 XHE £8 aHo| S/} I3t e |
4) CHERE QolE A s
- AEE O IjS He X ' fF\\\
_ MM 28l Hm Q0|4 ofQlo] Zt A4
HlD 9o/ 52 BE joto| 7hs

O X}& CHH|(Data Imputation)
435 d20M FSH X 25 52 2dA 0|8 7HE 240 8O[St== CHHM| Al7|=

o
ag|

ne J
ol

1) AmosO| MEt 7tsot Xtz CHA| B
o 2| TCHA| 2
- 7t dE mEhof 2l CHA|
- SPSS O M= AL Tt
o SEUHEA 3|7 CHA|

i

- Z ol o5l BtEXCoE XIEE N — P
BN e HolE 2 4y & ="
A%/2 8 A e

o HIO|X|QF CHA| E Ee e |
.
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Amos &2 % 7|5 (4)

o 2g AT (Ho[x|etet 7}5)

Z0{Zl H|o|& & 0| &3}0] theol (§I?l)71l—’|*— US FYst= Y-O| ofL| 2t HIO|H
LSO AFE R RS o iﬂ”* dA®s L+ A4 NEz A+ =82
o, =X 210 LiE EE ot 223

=20 | L= L, IE Xl =
1) AES U= HoME B 27 2Aa} — _
£ Posterior Predictive Distributions e
o =l O} =0 = performance dnsage‘(c\us\er )‘(C\us\
-|-|-A|'0|_|' E—Tl—El D—E A-"T'__ I' 1] 212081284007218 6 .66331007802931 0.08
2 15.6967674948943  5.66102565586862 0.00
=1 H35le JLl-= | 5| 192040361185385  6.05921131399695 0.0
2) T'__E'l_:I E”Ol '|7|' _I_O'le—T'—, == ol'l_ | 4] cavsercrssrasr  sraversassaros 0.0
5| 20.9390517036103  6.94140644349163 0.00
- |~
St 218 Gl0|E| 7k FOIXIX| g 2 oo e 2
| 7| 13.0s0630810040¢  417850111796280 0.00 b
B| 225151875204982  5.07213560523647 0.00
23S Bl B0 92 B o s— 00
10| 19.548088381881 7.85787654574786 0.00
11 s =
3) oI 24 ZopojA, H/H0| 2 242 12 v '
13| 15.0037101134325
=&st=0|, HolH 50| 20N Us R
I
ﬁ 25.7369478114549
710 M I:ﬁ | 17| 15.3802700800774
oT, o= _'_El E 23.677847016763
. 19| 2691237010835 | | . I
S QDUS MRSl HY So &R Jts 5 e Fommmtm—e— |
g mn * I

1) AMOSES SofAl BHE =% (2433
olthEl Rr=eAo| Jhsete, Mot [PoY B
gomNe iz g olse M (SRRT | mml
2) A7\ | $HES stEiN, 7jgole (TR L
S0l T3t 2o/4S At w

=
3) T o= 28O 7ts
4) AMOS LHFHS =2 B 20t5
A8t HM 829 72X
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Amos F2 52 7|5 (5)

oZRf|U pEZ Y MM
Path DiagramS A& 12|X| %1 Visual Basic 5 C# HAo| HAEES 2310

2 4Y s

e P Ne) name <Group
1) HEHo R FASt RYS o2 M 1240f — - .
N N Il it: o Phugins. Alt+Fg
Cél- 701_?_ DH_?_ 'IQF%OI:II- :lg Draw Covarances M
i 1= Growth Curve Nodel
- o zE Name Parameters.
2) 2ol 47 & 82 tojoads A rEk R |
Resize Obsenve Variables
:LE'E ZdEEl. -é-%&ll OEI @E == sundudzed AR D
[ D p—
Znauio
E
rr ==
Cosngta srvces - ‘
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Amos New Features [£X7|5 Z3H

O D-separation Analyses
HEA7|E 18450l 2 RChat &2 7o £

I_I_

i
or
r
.
+
1
o

D-Separate £ 2 T¥5l= Ml 71X WY

= ==
O] 3l M A HIAE Z3o0| LIt

¢By Unnamed project : Group number 1 : Input

File Edit Diagram Analyze Tools Plugins Help
4 Interface Properties Ctrl+l |
i Analysis Properties. CirleA
4« { W OBject Properties.. 0 [ Analyss properties
Variables in Model.. Cirl+shift+M
£ Variables in Dataset Ctrl+shift+0
By Parameters... Curl+shift-p
5 ™
. B Switch to Other View Ctrl+shift+R
O Bl Text Qutput F10
() Full Screen FiL
: CDeRUl model
5 o) I

2) 2) Analyze > D-Separation Preview 2 &l. D-Separation =440 ZA| =3,

of £39  Group number 1 : tnput

Flle Edit View Diagram Tools  Plugins  Help

alculate Estimates Ctrl+F9
“— é — W Manage Groups.

= W Manage Models
[itief 5 . & Modeling Lab.
dm M . Toggle Observed/Unobserved
or Degrees of Freedom.
@ ™ X
4 O 5}1 # Specification Search...
) 23 Multiple-Group Analysis...
=] \) e A Bayesian Estimation. CtrieB.
%24+ oata imputation
i u
m K’@ (i} D D-Separation Preview
o I = T
fua] Refy
i "

3) Tools > Export to > DAGittyS 28/. 0| 4@ ZH0| S EEC0 SAL| 2

22X 0| M dagitty.net I O|X|S {1 Al =g
— Ot & RES S EHEE0A dagitty.net 2 HOX[Z 20 E& &

S

http://amosdevelopment.com/video/dseparation/DSeparationTry1.mp4

& 211714  Group rember 1~ npot IR 0 —_—

Expart o DAGity

FOl

tot

.

Analysis Properties > Output2 22|, D-Separation &0l M3 &EA|. O

42 Analyze > Calculate EstimatesE 2 25t D-Separation &A1
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Amos New Features [H 2] ZsH

o &% M d= &9l (1/4)
File > File ExploreE 28/5t0] = 02l Z =2 Ct0|0{ & T (*.amw)O|

Windows T+ BA7|2] 0l E2H0| M &[0 A=A =22l 7ts.

TH EH47] 7|

olr

® File > File ExploreE 22510 22 S0l ZZ Ct0[0] 12 I (*.amw)O|
Windows It EfAM7|0l o= Z2H 0| MY A=K =2l Tts

%y File01 : Group number 1 : Input
Edit View Diagram Analyze Tools Plugins Help

O New

& New with Template... | = | Bxamples

far B O Tl = == =

B Retrieve Backup..

B/ sae Tt « Local > AmosDevelopment > Amos > 25 > Examples

E‘ Save As... oz -~ e

B2 save As Template.. 3 B2 247

E  Data Files.. m HE 3E » Engfish 20171214
thezc Japanese 2017-12-14

i i 3 OREC

@ | Print [ Fileot.AmosLock 2017-12-14

E1  Browse Path Diagrams = A * fb File01 2017-12-14

S File Manager...
‘ F2 C10|0j WS NHSIA| %L FS T EA7|o|

5 1Y NBRK B8 24
g XEH| QI3 7|2 BT EAIE

O OMoY ALE E2{27| (2/4)
=8 20| & AFEA QUM 2| Off M| ThE M= =327 7ts.
*OfH THE 2 oot 20 HE2Z NS

Of| x| ot EC HIS

® Amos 255 ARSI ALEALHO| JimY 42,
T4 BAIZ0 of2ier 22 E= .
CWUserst)imWAppDataWlLocaltAmosDevelopment#AmosWw25¥#Examples
| s | Examples

Dot
o

& 27

= v 4 | C:WUsers*NJimV*AppDataWLocaIWAmosDevel0pmentWAmosW25WE)(ampIes V| - | Exam
olg : +h8 R 24
3 B2 717
: _19- s ool =
. e ’ English 2017-12-14 9-: 4. f|'E = f
3 Japanese 2017-12-14 2% 2. It¥ £GH
o 3 OEEE
w

Ll
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Amos New Features [H 2] ZsH

O Ojo|Eut = mpet (3/4)
View > Variables in DatasetO]| EA|Z|= By SE20|= ZF B0 Cist 71 YET}
HAILH #Ha 0| S0t H 0|2 H2 HE Jts.

View variables in dataset M|+

o o
#By Ex34-b - PossiblySetosa - Input oy Varaoles In Dataset 7 x
File Edit [View | Diagram Analyze Tools Plugins Help hams [ Label [ #]
""""""" 3 Interface Properties Ctrl+1 ®0359”D
= Cm Analysis Properties_ Ctri+A %Ee:a:ﬁﬁh g

_ - etal¥yl
— ‘_E.E..' Object Properties... ctl+0 @ SepalLength 2
= v .
g B Variables in Model Cirl+Shift=M 4 SepalwWidh 3
(Tl S8 Variablos in Datasel._ CinvshittsD | & Species 6
£ Q8 Pl s g
E  Switch to Other View _ Curl+Shift=R
@ ELl| Text Output F10
{:} Clil Full Screen F11
b | &y Valllgles in Dateset 7 4 X
L 8 9 Name Label | #,
® [O&: View—Variables in Dataset P !
caseno 1
4 Sepallength 2
A
- O|O|Ee mof B S =0| #A| @ Sepalwidn 3
% PetalLength 4
A 3 T .
- Hy SW HA  Petal idin 5
] Species E
q L o = o
Numeric( ) SE£ String ([A] ) 22 OF0|Z EA|
A =] = il
- g2 Vs ME

O Bd Hx 28 (4/9)
Amos ZHH X271t HE = EHE &¢H #E 5+ U= &d B (Environment

—
variables) 28 7ts.

=g it
[1. Window It EHAH 7|

T2 HAIEO| %amosexamples%E 22540 Window IHY EA7|0IM ZH & 7|

| < | English
mrol I E
s | O2=RE —
.‘ ‘ t « v « Amos *> 25 > Examples > English
el = =] ~
Bl s e > e ~ o P
HtEl o
« v ‘ ﬂ%amosexamples%‘ V|—) 7 m e VisualStudio 2017-1
7oA [] Attg_old.dbf 2017-0
> e @A Attg_old 2017-0
> & 2E a3 Q) Attg_old 2017-0
> e B2Z 023 @) [] Attg_yng.dbf 2017-0

[2. Amos It CH3t&bA}

: Amos It Ci3HAMXLO| %amosexamples%S Q1250 20

*E71 .t
”‘g‘ Unnamed project : Group « “ 4« Amos > 25 » Examples > English

File | Edit View Diagram E- M=

ZRIY ~ olE
D New -
{5\3 a7 & OneDrive Visualstudio
~ .
= New with Template... - €74 Ex01

= o T Ex01-a
= Open.. « v 4 %amosexamplesde - £Te £x02

[ oa=t Tt Ex03
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Amos New Features [T2]d

O Path Diagram Output X} S &3

View > Interface Properties > More M2 &4l At&2 2 Output=

View variables in dataset |4+

|
o |
Fle i View Diagiam Analyze Tooks Piugins Help !
- T By inter
@ ¥ i Stan |
— & Page Layout| Formats | Colors | Typefaces | Pen width | Misc
[ ——
we F R I
R e ('F:
@m™A \ I~ Automatically show text output
#OF N
[ESS——
= | E———
o ]
“
=]
i e
o Path diagram | Syntax
it estmating any user-defined estimand.

=l

W #utomatically show output in Path Diagram view and Syntax view

More | sccessibility | Syntax |

S IojEfE R

? ES

e Oj‘F: View > Interface Properties > More

> Automatically show output in Path Diagram view and Syntax view

- Calculate estimates& Aot £ A& 2 2 Diagramd} path0i| OutputO|

gt

O Stan L ELY{7|

Bayesian Modeling Program@! Stan2 2 Amos Z &S Li2'd ==

Stan LHEL{7| Z=H|

[1]. View > Interface Properties > StanO|A] ZH S Lj = LY

- Stan M 2 DY 7|, Cmd 27|, Cmd Stan IDE 7|, Rstudio &7|

T4 Interface Properties 7 .
Page Lalwml Formats | Colors | Typefaces | Pen Width | Misc | More | Accessibility | Suntax
Stan

Before exporting Stan files

I Ask where to save

After exporting Stan fles
@ Open Windows File Explorer
© Open a command prompt
© Open the CmdStan IDE
© Open RStudio

Location of CmdStan

Location of AStudio
|CiwRragram FilesWRStudioWhin

=

#8x Unnamed project : Group number 1 : Input

= @
+— —
e B =2

¥+

Group number 1

3¢ Default model

Tools | Plugins Help
4 | Data Recode.
[A] | List Font..
HE | smart
% outline
O square
3 Golden
By Seed Manager
& Write a Program...
Export to v

ol g 4

A

A OlS
AAO.
- N
= d3E N3

| DAty

Standardized sstimates

Path diagram | Syntax

Mot estimating any user-defined estimand.

| stan

Export to Stan

(e]]
PN

[2] Tool > Exportto > Stan 22 Z}gst B & LHE LY 7|

-DES e F Yot

=40 et H3e Z= 0|

AlSl
=

o
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Amos New Features [Amos2} R Project & 8Hd Z3H

O R HIO|E mY E2{27] (1/2)
REZI 4% RF0| 24 gl0], R HlOIE It (* rds % * RData Tt2) 917| 7ts.

*rds % * RData It E2{27|

£ Unnsmes project - Group number | < input

Data Files
Fila| £t View Disgram Anahze Tools Plugins Help
0 New Group Name | File. [ Variable [ Vahe [ W |
2 | Neow with Templsta_ Geoup number | <working> «
& Open_ =
@ Retrieva Backup.. -
v Examples 2%
B save cties O] | Bamp L
& Savehs. o
& Save As Template b= o e
([0 Deta rres.. CuieD |l File Name ‘ Help ‘ P 2]
@ | Print...| Select data filefs) | Ctrl+P o me =g dBase Ill (~dbf)
3 Browse Path Diagrams. Mew Data | 3 ‘ ‘ T 1= = | dBase IV (i)
22 File Manager. 2% Tr2 =Ci[dBase 5.0 (*dbf)
File Explorer 0K Cancel Excel 5.0 (*.xs)
— Excel 8.0 (+s)
Sl I~ Alow nan-numeric dats I Assign cases 1o groups: Excel 2007 (s
] [ | strdarcoss estmares Foxpro 2.0 (~dbf)
Foxpro 2.5 (+dbi
iR e otpro 25 (-dbf)
@
@ R - Rds (+1d5)
(=% b 270 BT M2 7ty QEAQ NS Ty M Access (mdo)
) IBM SPSS Statistics (sav)
A 2% Text (vtxt; *esv)
. ST |AmosRecode (+AmosRecode)
Ity o|E(N): v | [Rds trds) ~

* Lotus G|O|E| MR % Excel 3 X Excel 4 CIO|E Itof Cist X[ ST

O REZZIH LHo|A AmosE A3 (2/2)
KoreaPlus Statistics | Q! H| 70 Al AmosE A M= 40t FASIAH R Z2 13
Lol A Amos A& 7t

“amos"&TE 8% Amos HH
SIHH 64H| E/32HIE O{F0f 2} source( 'C:/Program Files/IBM/SPSS/Amos/25/R/Amos.R")

L= source( 'C:/Program Files (x86)/IBM/SPSS/Amos/25/R/Amos.R’) RZE A2l
281

amos(data="", model="", wait=TRUE, run=FALSE

amos <- function(data="", model="", wait=TAUEZ, run=FALSE
{

Manual page for the R function, amos

AmosProgramFolder <- readRegistry("SOFTWARE\\Anos\\25.@", "HLN™, view="32-bit")sDirectory

anosCommand <- paste('"", AmosProgramFolder, 'AsosGraphicsCLI.exe Description
amosCommond <~ paste( AmosProgramFolder, 'AmosGraphicsCLI.exe’, sep="")

Executes Amos
arguments < vector()

dataFileHame = ‘ Usage

usingTempDataFile = FALSE R _
if (is.data.frame(data)) amosidta=", nodel=", wat TRUE, uneFALSE)

datarileome - tempfile(fileext="_rds") Arguments

data, dataFileliame) i

st ) e - intane, dutaFilotons) data The name of 3 dataframe.or  charactr ting tat g the pathtn an rds data fle.
else if (cata = ™) model A character strng that gives the path to an am fl that contains  path diagram. If model="" {the defaul] Amos
1 opens with the most recently used amw file.

dataFileNane - data pers t
| erguments - clerguments, '-indata’, datafileliane) wait  IF wait=FALSE, the amos function returns (and your R program cortinues to execute) as soon as Amos starts to open.

If wakt=TRUE (the defauit), the amos function does not retumn until the Amos window closes.

if (model 1= *7)
F nn IFrun=FALSE (the defaut, Amas opens and then wais for user nteracton. Incther wads, Amos waits or a ser to
| rguments < clanguments, ‘-model’, model) do something with the mouse or keybaard. If run=TRUE, Amos performs the following sequence:
3f (ram == TRUE) Amos 1. The Amos window opens.
" arguments <- clarguments, *-plugin’, ‘CalculateEstinatesAndExit.vh') 2. Ames fitsthe specified madelto the speciied data set (as though a user had cicked Analyze > Calculate:

Estimates.)

3. The Amss window coses (as though 2 user had clicked Fle > Ext)

system2(amosComand, argusents, wait-wait)
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KoreaPlus Statistics7} M X|E|X| &2 A0 E Amos?| View DataZ 0| A Statistics
HolH m(sav OtY) 27| 7ts

Data Files > View Data

Ol % : File — Data Files

yata Files T+ spss sample data.sav - O X
& I T e el i File Format Help
roup Name ile ariable [ Value
[Group number 1 spss sample data.sav 10410 | : HANHEHY | 2|99 =
3 h
2 36 57
3 43 55
4 45 70
B 58 T2
6 60 N}
File Name | Working Fle | Heln | 7 &0 a0
3 80 81
view Data | Grauping Variable | Graup Value | g 3 A
10 100 60

aK Cancel

[~ Allow non-numeric data [~ Assign cases to groups
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KoreaPlus

O Plugins M|+
HOJEfE R MM =5
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* Amos 2581 B H 7ts

Z3tE =T}

Plugins > Export output to MS Word

S B ALS B 39 24ZE S0

View Diagram Analyze Tools

HEZEM2E ; Group number 1

Plugins | Help

—

: OK: Default model

enty

S IojEIE S

A(docx) 2 LHELYZ| 7|5 74

I(doc) 2 WELYZ| 7ts

- o

‘ ©  Plugins. Alt=F8
[ Export eutput to MS Word
L Draw Covariances
| Group number 1
= Growth Curve Model
= Name Parameters
41 »
) Name Unobserved Variables
Resize Observed Variables
A standardized RMR
"
%{) O#: Default model
>3
W Unstandardized estimates
/" | Standardized estmates
@ =) B i e v R TT T T TP — - oEN
7 ER: - = wn o = N T )
Q.Q@ [ -ﬂ'ﬁr;:},” =l a
A & | A m e e o5 |sna| G
== Minimization ~ e e 2 a4 ¢ me| B [T = e
) Cu M Iteration 4 mesc o &5 ] 4
» s 1| Minimum was achievec o e u L = (|
\riting output et e e — e e
Chi-square = 01, df = T T
v R——
< > G Dy o Cwgrowe o (rowom et e o= N
—
oo Wanbes o distinct sasls moments. 10 a5e
3=gsog Number of dis#ncl parameters fo be estinaled. 8.
Dearsseat bescomi- B, 2
P
i was sctoved.
g r
om =
b 35 |
[EUR [ S ————

Not estimating any user-defined estimand.
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